Acm试题及答案 下载本文

内容发布更新时间 : 2024/5/5 16:24:15星期一 下面是文章的全部内容请认真阅读。

Acm试题及答案

Acm试题及答案

1001 Sum Problem ............................................................................................................................ 2 1089 A+B for Input-Output Practice (I) ......................................................................................... 3 1090 A+B for Input-Output Practice (II) ....................................................................................... 4 1091 A+B for Input-Output Practice (III) ...................................................................................... 6 1092 A+B for Input-Output Practice (IV) ....................................................................................... 7 1093 A+B for Input-Output Practice (V) ....................................................................................... 9 1094 A+B for Input-Output Practice (VI) .................................................................................... 11 1095 A+B for Input-Output Practice (VII) .................................................................................... 12 1096 A+B for Input-Output Practice (VIII) ................................................................................. 14 2000 ASCII码排序 ........................................................................................................................ 15 2001计算两点间的距离 ................................................................................................................ 16 2002计算球体积 ............................................................................................................................ 17 2003求绝对值 ................................................................................................................................ 18 2004成绩转换 ................................................................................................................................ 19 2005第几天? ................................................................................................................................ 21 2006求奇数的乘积 ........................................................................................................................ 22 2007平方和与立方和 .................................................................................................................... 23 2008数值统计 ................................................................................................................................ 25 2009求数列的和 ............................................................................................................................ 26 2010水仙花数 ................................................................................................................................ 27 2011多项式求和 ............................................................................................................................ 28 2012素数判定 ................................................................................................................................ 30 2014青年歌手大奖赛_评委会打分 .............................................................................................. 31 2015偶数求和 ................................................................................................................................ 32 2016数据的交换输出 .................................................................................................................... 34 2017字符串统计 ............................................................................................................................ 36 2019数列有序! .............................................................................................................................. 37 2020绝对值排序 ............................................................................................................................ 39 2021发工资咯:) .......................................................................................................................... 40 2033人见人爱A+B ....................................................................................................................... 42 2039三角形 .................................................................................................................................... 43 2040亲和数 .................................................................................................................................... 44

1 / 45

Acm试题及答案

1001 Sum Problem

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1 100

Sample Output

1 5050

Author

DOOM III

解答:

#include main() {

int n,i,sum; sum=0;

while((scanf(\,&n)!=-1)) {

sum=0;

for(i=0;i<=n;i++) sum+=i;

printf(\,sum); } }

2 / 45

Acm试题及答案

1089 A+B for Input-Output Practice

(I)

Problem Description

Your task is to Calculate a + b.

Too easy?! Of course! I specially designed the problem for acm beginners.

You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim.

Input

The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 5 10 20

Sample Output

6 30

Author

lcy

Recommend

JGShining

解答:

#include main() {

int a,b;

while(scanf(\,&a,&b)!=EOF) printf(\,a+b); }

3 / 45